请选择 进入手机版 | 继续访问电脑版
 找回密码
 立即注册

QQ登录

只需一步,快速开始

IE8非兼容性视图下无法申请网站和排版的解决方法

由于IE8从ie8.7600小版本后不再支持setExpression,使JQUERY的BLOCKUI无法正常弹出层,会导致IE8在未设置“兼容性视图”的情况下,出现以下问题:

1、无法在代理网站申请试用站点
2、无法使用网站排版的插件设置和其它采用了BLOCKUI的功能

有两种方法可以解决此问题:

一是让用户设置IE8“兼容性视图”,但是这个方法对代理网站申请试用的用户没有意义;

二是修改网站的base/templates/header.htm

在<head></head>之间加入

<meta http-equiv="X-UA-Compatible" content="IE=7" />

加入这段代码可强制以ie7的兼容模式来访问网站,此修改不影响其他浏览器的访问。

我们会在PHPWEBv1.4.5升级中作此修改

在升级之前,代理商请务必在代理网站加入此段代码,否则会影响IE8的用户申请网站。
您也可以联系技术支持,帮助您进行修改。

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

    热门帖子
  • 精华
  • 新帖
快速回复 返回顶部 返回列表